Hitbox making player bug-out

I’m currently in the process of making a melee-combat game. I just experienced a very large issue. I have a hitbox which is just a large part around the player (inside the player’s character)

Unanchored (since welded) and Can-Collide is false

Here is my code:

		local NewBox = game.ReplicatedStorage.PlrHitbox:Clone()
		NewBox.Parent = Char
		local Weld = Instance.new('WeldConstraint')
		Weld.Part0 = Char.HumanoidRootPart
		Weld.Part1 = NewBox
		Weld.Parent = Char.HumanoidRootPart

It’s acting as-if cancollide is true, and I’ve double checked, and it’s false! Why is this happening?
I’ve never made anything like this before. So any clue on to why this is occuring would be really helpful, thanks!

Try setting the parent of the box to the root? I have no idea why this is happening to be honest.

Check if there isn’t any other part in replicated storage with the same name (PlrHitbox) that has cancollide set to true, if not then just set the NewBox collide to false through the script itself

I checked, there’s absolutely nothing else.

I solved it, I don’t really understand it but setting the Property “Massless” to true on the hitbox somehow fixed it. Which is still weird because cancollide was false.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.