Holes in the union part still collide

Whenever I make a union, even if I make holes in it, I collide with the area that has been removed using negate. Is there any way to fix this or is this not able to be fixed?

1 Like

Blender. Roblox studio unions are really bad currently, I just suggest making your unioned models in Blender instead

1 Like

Hello! When making a union, roblox simplifies the geometry and it sometimes (and often) messes up the collisions. The main fix is not to use negative parts and just build as you normally would.

There is a plugin which allows you to show the Decomposition Geometry.
And I recall having read about a Feature on the same subject.

Hope this helped!

You must set the part to noncollide BEFORE you make it negative and union it with the other part.

(This is the case wether or not you want the final union to be collide or non collide… or the negative part you unioned wont remain noncollidable.)


As @sonb0t said, you can use blender instead, since it has all the stuff Roblox has for unions. Here is a ‘tutorial’.

(note that I suggest lowering the vertices on the cylinder since that may cause a bit of lag for the player)


Like what @sonb0t and @no_tsi said, it’s better to use blender since roblox kind of uses it’s system of unioning things anyway. But, you could try messing around with the Collision properties. I forgot what it it’s called at the moment, but it helps with changing how the collision box is shaped for the union.

It’s called CollisionFidelity, you can read about it here. That could help!

And quick little reminder @gabrielofdoom, remember to mark something as solution if your issue was fixed!


Also, click this setting here it will help you see what your unions look like with collisions, this will help you determine whether you need to reconstruct your union:

1 Like