Hollow unioned parts bug

So I made a hollowed square using four different parts, like this:

but when I union them to be one part somehow, I can stand in the air on the edges.

Any solutions to fix that?

Im pretty sure there’s a property in unions called “CollisionFidelity” try setting that to precise.

CollisionFidelity to PreciseConvexDecomposition.

1 Like

Tried that and it does not work

Try enable in studio settings “Show decomposition geometry”

Hey @Koki0991, As @SomeFedoraGuy mentioned, try to set collision fidelity to precise (in the property editor for the union). @GamEditoPro’s advice is also pretty good to actually see the convex decomposition itself.

In general, if you have something you think is a bug, feel free to share an .rbxl file so we can debug it


I tried and that’s working. Thank you for mentioning it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.