How can I fix this slope problem?


#1

So, lately, I’ve been noticing that the slopes I have in my game seem to make it where it difficult to get up even though before, the slopes acted completely normal and can be walked up easily with no problems.

I’ve tried looking on the dev forums and roblox wiki if any changes were made to slopes during the time but couldn’t find any.

Problem:

As you can see, instead of me smoothly going up the slope, It instead stops me and forces me to jump up slowly.

Is there anyway I could fix this? (Ignore the weird hitboxes on the slopes, unless thats the problem?)


#2

Don’t make the ramp too abrupt, instead, make it steady. I also recommend making the amount of polygons in that ramp higher. GL with this game! It looks amazing!


#3

I believe the weird hitbox is because the ramp is unioned

also for fixing the problem you could maybe try to add some sort of velocity to the part to move the player (like conveyor belts)

Edit: Just tested it and it works

without velocity script

with velocity script

script I used

local Ramp = game.Workspace:WaitForChild("Ramp")


for _, Part in pairs(Ramp:GetChildren()) do
	if Part.Name == "Final" then
		Part.Velocity = Vector3.new(0, 90, -90)
	else
		Part.Velocity = Vector3.new(0, 0, -90)
	end
end

I set the first part of the ramp to just have a velocity on the z axis, and I added velocity to the y axis to the top part of the ramp

this script isn’t ideal as I made it in 2 mins you could tweak the Velocity and edit the script to be better for what you need

Though if you don’t know how to script I’d be happy to help you out more with the script for free of course just shoot me a dm or reply


#4

You could try changing MaxSlopeAngle https://developer.roblox.com/api-reference/property/Humanoid/MaxSlopeAngle

I recall recently (last 6 months maybe?) there might have been some changes to how these settings work or there might have been a global setting added somewhere. Not sure the details but I would look in that direction.


#5

It works on some ramps but not so well on others. I wonder why its happening now though :thinking:


#6

I don’t think its because of MaxSlopeAngle, when I checked, its 89 on my character which is max I think.
Also, a bit weird they changed something with the movement 6 months ago :thinking:


#7

That is because the velocity is in a certain direction e.g one ramp would need -90 velocity for z or x and another ramp rotated would need 90 etc


#8

Yea, already did that :sweat: but since theres still a slope problem even with the fix of the velocity.


#9

if the ramp is a union try separating it


#10

After a bit of hassle trying to turn it into parts, It works :smiley:
Thank you for helping btw :stuck_out_tongue:

(Still weird that you have to do a workaround to fix that as it worked completely normal before…)