How can I freeze this and make it not move?


So, I need some help with the game screen GUI. I have this application center up and running, however, it works but you walk at the same time along with the application. Like it moves around, does anybody get what I’m saying? Does anybody also have the script into freezing the background screen so users can mainly focus on the application?

You can always set the walkspeed/jumpower of the player to 0 Or just disable player spawning (A property of the Players Service). Those are the easiest solutions i can think of. (that is if am getting what you’re asking correctly)

Could you provide a GIF so we could see whats happening and understand your question a little more? As others have said, you could just disable player spawning entirely if you aren’t using the player at all. If you do need it, just set the players walkspeed to 0 and back again when the player needs to walk.

What are you asking here?

Go to your Starterplayer and change the walk speed to 0 or change it in game settings. Gane>StarterPlayer>WalkSpeed

What I’m asking is how can I remove the top bar you just see the GUI?

Oh, so you want to destroy your core gui?

I used the script:



local starterGui = game:GetService(‘StarterGui’)

starterGui:SetCore(“TopbarEnabled”, false)


I did destroy my core GUI, chat is gone everything as you can see in the picture. I just need it gone fully. And just a full screen of my current GUI.

Usually what I do to avoid all input into the character is use ContextActionService to bind an action over the controls.

If you are talking about making the background static so you dont see the workspace, you can use StarterGui:SetCore("SetTopBarTransparency",0) to make the top bar non-transparent.

1 Like

Which I mean, I just want to see this:

In which category on studio? …

This is actually a method you have to call in a script. You could probably just make a local script that executes in either ReplicatedFirst maybe or StarterPlayerScripts:


It won’t cooperate in the game. Sadly.

Another way to make the gui take up the entire screen easily is by setting IgnoreGuiInset on the ScreenGui to true.

you can always set the Transparency of it to 1 But that doesn’t really help it, Does it? So instead you can Instance a frame that will overlap the default top bar.

local barFrame ='Frame', script.Parent) -- The script has to be in a ScreenGui
barFrame.BackgroundColor3 = Color3.fromRGB(0,0,0) --change the colour here
barFrame.Position =, 0, 0, -36)
barFrame.Size =, 0, 0, 36)
barFrame.ZIndex = 2

@goldenstein64, That works but i don’t think that’s quite what hes looking for, I am pretty sure he wants a way to change the colour of it.

Use that from a local script.

local StarterGui = game.Players.localplayer.StarterGui

You can also change the topbar color to fit your needs (so it blends in with your GUI) by setting the transparency to 0.5 and putting a frame under it.

Thank you! This support is now closed, all of your comments on helping me fix this was very helpful to me.

Make sure to set the reply that solved your problem as solved! It will help other users quickly find a solution if they have the same problem.

1 Like

You can anchor the player while Gui=enabled

1 Like