How can I hide the proximity prompt gui while keeping it enabled

So I’m trying to use the new proximity prompt object in Roblox and I would like to hide the GUI that shows up when you’re within range of it. image

I have tried setting the offset too far away but it still shows and if I were to disable the proximity prompt I will not let you use it.

Does anybody have any ideas?


From what I know about ProximityPrompt, it does not have a property that could somehow give you the solution to this problem. Again, I am unsure, I recommend reading the post about ProximityPrompt as there may be a solution there: Proximity Prompts | Documentation - Roblox Creator Hub

Set ProximityPrompt.Style to Enum.ProximityPromptStyle.Custom.


Thank you for your help. It worked.

what about when i want the prompt to show up for certain players?

example. if i have a battery, i can interact with the generator. but if i don’t have a battery, i cannot interact with the generator.


You can edit the style values locally through a local script and a RemoteEvent from the server to the client

You disable it by properties, but locally enable it for players if they have said tool.

1 Like

This won’t work in my case because:

  1. I want the default Proximity Prompt to be shown when the player approaches the object
  2. When the player presses ‘E’, the Gui must be hidden (but the Proximity Prompt must remain active)

If I set the Enabled property to false, PromptHidden will be executed and that is not right because the prompt is still active. PromptHidden should only be executed when the player presses ‘E’ again (or when he moves away from the object).

In short: how to disable Proximity Prompt Gui after the player presses ‘E’ (and not run PromptHidden)?`


Nvm, I found out how to disable Proximity Prompt Gui after the player presses ‘E’ (and not run PromptHidden):

  • Inside ProximityPromptService.PromptTriggered, set game.Players.LocalPlayer.PlayerGui.ProximityPrompts.Prompt.Enabled = false
1 Like