How can I lower the amount of lag created by large-scale models?

I’ve made a forest, and it has a lot of trees, obviously. When I test the game, it creates a lot of lag, and when I remove the forest, the game becomes a lot smoother. However, I need the forest. How would I lower the lag, because there are around 500 trees and somehow it’s still a small forest. I’ve tried looking online, but nothing has proved fruitful. Streaming won’t work because it causes errors in my scripts due to far away parts not existing.

5 Likes

To be honest with you always tend to have the same issue. I thinks you just have to try your best to ignore the lag. There isn’t much solution except trying to minimize the builds. For example: getting rid of a few unesscary trees. Hope this helped. Good luck.

1 Like

I presume these are mesh trees, could you try a chunk loading system exclusively for your terrain? Maybe use the atmosphere lighting system to mask far away buildings/items that scripts depend on that you don’t want to be affected by the chunk loading?

1 Like

I would probably either put less trees, less parts in the trees, or make the trees into meshes.

1 Like

Similar to a couple other people’s replies, I recommend try making them meshes or simply remove a fraction of the trees to hopefully make it run more smoothly.

However, something to consider is that (correct me if I’m wrong) Roblox has been experimenting with features to make very large scale maps. Which will hopefully open up the option to make average sized one’s run better with more complex/detailed builds and models.

1 Like

Some things you can do is make the parts that you cannot touch have can collide set to false and make the trees consist of less parts. If this doesn’t work, I suggest making them in blendr if they have not been made in blendr already and they are just parts.

1 Like

No, actually, they’re not mesh trees, they’re just normal trees made of parts.