How do I access User Ads?


For some reason I can’t access User Ads and the site is giving me 0 indication for why it’s happening. I can run Sponsored Ads just fine, but whenever I try upload an image for an User Ad or even simply navigate to user ad page directly, I’m redirected to Create home page.


It’s giving me a vibe that for some reason I don’t have an access for the feature, but I haven’t found any information about that.

Hope there’s someone here who can give me some guidance, because Roblox Support just kept telling me turn off adblock, despite me listing multiple cleanly installed browsers that gave the same result.


Roblox support is very vague on that issue. Never seen an issue like that before

I have a talent of stumbling upon exotic issues, I guess. Or this is something absurdly trivial, like maybe I haven’t checked an important box somewhere, but it would be nice to know. Maybe it takes a week to approve an ad creative and I’m resetting that process by attempting to upload an ad from other browsers.

1 Like

Ads should be pretty instant in the uploading process…

How are you accessing the website to upload the ad exactly?

The correct method is:
Visit creator dashboard at
Select your game
Select Advertise from the hamburger menu on the left

Also just make sure it’s the right size as well and you can also try to download the provided template (try with a different image or a different image format as well)

It should be, but it isn’t. That’s why I created this thread.

1 Like

Ever try clicking “manage my experiences”?

Alternatively accessing it using a link like this:[game id]&targetType=Asset

Replace [game id] with the ID of the game you want to Sponsor.

Do you even read the posts before replying?


Yes… I do…

It seems like after you click the “upload” button, Roblox is trying to redirect you to the creator dashboard.

The page which you are getting directed to first is Create - Roblox (

From Create - Roblox you would be redirect to the creator dashboard at

However it seems you are getting stuck at Create - Roblox
This means you are unable to access the creator dashboard in this instance for some reason

Have you?
1 - visited the creator dashboard before at
2 - Signed in on the creator dashboard at
3 - have you clicked “manage my experiences” to acknowledge that the creator dashboard exists (this is to prevent you from getting stuck on that page)

This is how you can check if the ad was uploaded.

I saw no mention of you doing this in the original post, so I am going to assume you didn’t do this.

If it didn’t upload, then that is a website but that you should DM bug reports for

It also says that the image needs to be approved by a moderator, so that might take a while .

That was my initial guess, but it has been over a week and I can’t even access the page which is supposed to show at least an empty list of my ads. This looks like an issue with permissions and I’m still paranoid I haven’t checked some box somewhere (but nobody said anything about any settings).

Or maybe this is how it supposed to work.


I think there is a button saying “my ads” and I think it will supposed to show your created ads.

Could you give me a direct link to the page that shows user ads (strip all ids from it if there’s any), unless it’s the same I already tried :

For example, this link redirects me to Create page. Does it do the same to others?


Try to wait a little bit between each ad request. You might be sending too many.

I’m having the same problem, I can’t access the User Ads page, and my friend who is working on my game with me can’t either. I logged into my old account to test if I could access the page there, and it worked. Apparently this User Ads function doesn’t work for new users? I don’t know if this is a bug or if it’s on purpose.

1 Like

Wow, thank you, I was thinking that maybe I’m taking crazy pills, since everybody seem to not having any issues and not understanding what I’m talking about. Still waiting for the answers from the support, hopefully this will be solved in some way. I don’t have an old account I could use…

1 Like