How do I fix this animation glitch

I am making my own walk animation for a sword. But with the animation I made the player kinda bounces around because of the default walk animation. What should I do?

I’m not sure if this is the best solution.

You can add a script when a player respawns/joins game that removes the default walking and running animation.

If you don’t know how to do this, please let me know.

Change the custom animation to not move the legs and torso, but allow the arms to move. This will make it so that the arms wont be snappy with the default animation.

If you don’t want the default animation as a whole, I say remove it entirely. This can be done via testing studio and grabbing the Animation script that sits inside of the players character.

this isn’t needed. You can just replace the walk/run animation id in the default Animate script

1 Like

I want it to only play the animation when that sword is equipped. But i think i could change the default animation when they equip it and hwen they unequip it i can change it back to default. I am going to try this.

grab the default animate script from a running game and insert your animation in the run animation

Like i said earlier, this wouldn’t work because i want it to only play when the character is walking.

Personally I would recommend an event where it temporarily disables the main animations while equipped and reenables the main animations once unequipped. Personally I took a break from scripts for some time to focus on building and blender more but I would assume that this most likely would be the solution.

1 Like

when i disable the run animation it still bobbles up and down and im not sure why

set the priority of the sword’s animation to Action, Action1, Action2 or Action3