How do i fix this bug?

Hello, Can somebody please help me with this. I made an model in blender, and when i import it to roblox using “Asset manager” alot of the mesh parts end up like this…

(I use Opaque if you wonder)

1 Like

Well you would have to flip the faces properly. I’d recommend just watching a tutorial or something since it’s been a while since I used blender, I can’t remember how to do it. But if you want the easier way just tick the Double Sided button, in the properties

Your normals are facing inwards instead of outwards.

  1. Select your mesh
  2. Press ‘A’ to select all
  3. Press ‘F3’, and search for “Flip”. This will flip your faces out to face the outside.

It may seem as though nothing has changed, but you’ll notice the difference in Studio. If you want to prevent this from happening again in the future, what you can do is check the ‘Face Orientation’ option under the ‘Overlay’ menu. Blue means it’s facing outwards, red means it’s facing inwards.

1 Like

Thank You! You’re a life saver

1 Like