How do I get rid of darker areas in unions?

Hello everyone, so I have a question about unions. I found that when I negate a union through code it leaves a darker area on it where the part was negated sometimes. It is not really shading because its always shaded darker no matter what the rotation of the part is. It’s more of a property of the part itself. This is what i’m talking about:

I can’t get rid of the dark area no matter what I try and it is sort of ruining my game because I need it all to be one colour. Does anyone know how to fix this? Thanks.


Try disabling CastShadow property?

Try enabling UsePartColor on the union properties

I’ve tried all the lighting and colour settings including CastShadow and UsePartColour but nothing works so far. Thanks. I believe it has something to do with unioning.

If the shadow displacement is really interrupting gameplay that much, put the union’s collision fidelity to “Hull” or “PreciseConvexComposition”

The shadows are detected based on collision squares relative to a light source, having it on default or box makes the hidden collision squares not precise enough to have precise shadows.

I don’t recommend this for all unions though since changing it to a precise collision like PCC or Hull will create more lag since there is more detail, therefore more hidden collision squares.

Thanks, i’ll try it out. Where can I find CollisionFidelity by the way? Is it under workspace?

It would have to be a prior union since you cannot change the property in runtime, make the part your negating into a union, enable UsePartColor, and then go find this property:


Change the Fidelity to Hull as an initial test, if it doesn’t fix then change it to PCC.

Thanks, but unfortunately all my unions are made through code in real time, not prior with UnionAsync(). :confused: Also i’ve tried changing the settings on the union in Studio but it still has that darker area no matter what setting I choose.

I think I know what the problem might be. The darker spots are from the part’s original darker areas from the lighting in the game. That’s why it works fine with neon parts. So that saying, does anyone know how to not have any darker areas in a part and just have it the same shade level (preferably none?). Thank you.

I don’t know if i am too late, but i found maybe a way for fixing this, you can update the SmoothingAngle to 1 and after that you can set it back to 0 and it should be fixed, i just tested that recently and it worked in case somebody is reading (SmoothingAngle is located in the Properties)


I can’t believe this actually worked.
Was I ever???

1 Like

Hm I am having this problem too and I’ve tried the use smoothingangle but those unions which are a bit more complex will get weird defects on some part of the union and I can’t seem to fix that.

You have to do the negation two times on both sides to get rid of the dark spots. It took me forever to find this.