How do I get rid of the weld between the tool and the hand?

I just recently made a Jetpack, With it being a tool. As you know if you have a tool, the hand is weld into the handle. I don’t want the weld, as it makes this weird hand decapitation.

image

Oh god

Ive tried searching but I don’t know the term of this. Any ideas? I’ve thought of animation, as I need to animate it as well.

2 Likes

I do not understand much from the picture, but from your description I can assume two things:

  1. Either one of the parts in the tool are anchored and it makes you glitch out
  2. Some script in the tool gives it a weld in which case all you have to do is remove that specific line

EDIT:

If you mean the hand animation when the tool is selected, I believe you need to remove RequiresHandle in the tool properties

Sorry! What I meant is that, I set a weld to make the jetpack go at the back. But the hand comes along with it.

image
Unequipped(Both hands are present.)

image
image
Equipped (Hand is moved to the back of the jetpack)

The script basically does this:

Jetpack weld > HRP

But when the script does that, Hand also goes with the jetpack.

I assume that is because the hand holds the tool because it has an handle, in which case you should try removing the RequiresHandle

https://gyazo.com/d791a05fe6c54a75f70f4bd2a9ee1a15 < No RequiresHandle, no hand animation .


I Assume it is this? It still won’t budge.

Is the main part called “Handle”…?

If so, rename it.

1 Like

I’ve Done so, But I cant pick the tool Up.

Every time you equip a tool with a Handle, “RightGrip” is created in your character’s “Right Arm” or “RightHand” for R15. RightGrip is the weld between the tool and hand, so just delete/disable it before you weld the jetpack to your back.

1 Like

Why not try add an animation that can override the weld between the tool and the hand?(make the animation basically lowering the hand down and make sure to set the priorities to max)

Ah, Alright I’ll try this first. Thanks!

Works Great! Thanks alot! Just had some few tweaks and there, but worked overall.