How do I make my punch animation work with walking animations?

So I have a punch animation that animates the feet and torso. The feet and torso seem to float when they are animated when the player is walking, and this is weird. Is there a way I can set the feet and torso animation prioritys lower than the rest of the body parts?


In the Animation Editor, there is an option that allows you to change something they call the “Animation Priority.” More information about it can be found here by scrolling down to the section called Animation Settings > Priority.

But I want to set individual part priorities.

1 Like

All you have to do it make sure the feet and torso have no keyframes and the walking animation should overwrite them


But I want them to have keyframes, as I want the feet animations to play during the punch if they are idle.

1 Like

I do not seem to understand what your trying to accomplish. As infranova said, simply removing a keyframe from parts will allow the walking animation to override them.

If this still doesn’t help you, please explain your situation better: what you have right now, what you’re trying to accomplish, what is should look like in the end.

Split up the animation into two parts - one with only the feet, and one with only the upper body.
Set different priorities on them, and then play them both at the same time.


There used to be a button where you can disable a part of the animation which allow other animation to override that rig point but I don’t know what is it currently, I used Legacy one not New one

Maybe you could try doing this Select a part that you don’t wanted them to be on each animation and do what this clip done I guess?

What he said, split them up into 2 different animations, except that you can’t play both, default roblox animations are on lowest priority so any animation overwrites them, i suggest that when you press punch, it checks if character is moving and plays either Full body (if not moving) or only Upper body (when moving or doing any actions)
check can be done by humanoid.MoveDirection.Magnitude (if it’s more than 0 the player is moving)