How do I optimize my terrain while keeping the size relatively the same?

I am developing a Grand Canyon sort of hiking simulator, and to capture the real feel for it, I and my partner decided to try and make the map absolutely massive. Because of its sheer scale, we needed to compensate for width and length by making the height the appropriate size. Ultimately, the map is 16384 x 10955 x ~1350 studs wide, long, and tall. Currently, for heightmaps, you can’t go above 1024 studs. I tried using the heightmaps 2 beta feature, but it fills in all the unnecessary on the underside of the map which ultimately skyrockets the voxel count, so I decided against using it. The map has 2 layers of maps stacked on top of it that needed to be imported in order to fill in the prerequisite that was the height compensation. Even with all of this, the map is still a whopping 95 million voxels! I’ve tried other methods of making a map at this scale, and couldn’t think of it anymore. The main problems I have with this are publishing and saving to Roblox, both of which fail as well as the time it takes to load into the studio world, (averaging 7 1/2 minutes). How do I optimize this terrain so that players can play it while still being able to take in the awe of its scenery (the game’s intended purpose)

For reference here is a studio screenshot.

Have you looked into Game Content Streaming? This actively loads and unloads regions of the world to keep the game running fast and allowing you to have a really detailed and large terrain. Read the article carefully though as it changes stuff locally (like clients not having the entire workspace at all times). The best practices gives you insight on how to correctly use it.

This may work for clients, but not too sure about the loading in studio.

Alright, so I did some tinkering. I seemed to make the load speed incredibly thanks to the game content streaming, yet I can’t seem to be able to publish the place at all. Every time I attempt to publish the place, it says, “publish failed”. Is there some way I can fix this?

Update on the Problem:
I deleted all the terrain and tried again. This time, however, I turned on the team create prior to loading the maps. After loading the maps, I finally got success in publishing the game to Roblox. I tried exiting and coming back in. When clicking exit, I was greeted with a terrain syncing message that said the terrain needed to sync before I could leave, even though the game had already been published. After it synced, I restarted Studio and opened the game. When I entered, I reviewed the map and found that not only had the top layer was completely deleted, but also half of the map! I checked the part counter and it showed that over 60,000,000 voxels were corrupted and deleted.
Here is a reference photo:

How do I fix this?

This is the message I got after I published the game and tried to exit

I’d suggest rolling back to a previous version to get the terrain back but I don’t know much other than streaming to reduce load impact

I believe I just fixed the issue by deleting unnecessary terrain and using a mesh to serve as fake terrain. Thanks for your help anyway.