How do I remove this weird glow on the trees?

So the title basically explains the issue I am having; when the tree top covers the sun directly, it adds this weird white glow. I noticed a single fix that I do not like as it ruins the realism of the game which is to turn the Lighting.Brightness property to 0. Are there any other fixes to this issue that keep the Brightness the same for the sake of realism?

What I’m talking about:
My current lighting properties:

demo.rbxl (32.7 KB)

1 Like

The links are screenshots, its from a program I use named Lightshot which is basically a Gyazo alternative. The links are 100% safe if its why you’re asking for direct images.

Download the files and upload them to the Developer Forum.

I’ve edited the original post with a demo of the issue with the exact same lighting settings as well as effects within lighting.

It might be a bug with the lighting technology’s interactions with textures with no backing. What lighting tech are you using? Voxel, Shadowmap, or future?

I am using Shadowmap tech. I’m quite sure its caused by every tech anyways.

I don’t think it’s caused by voxel. Try adding some opacity to the brick that the texture is on because it’s being back-lit. Even just a little opacity will make the shadowmap tech think it’s a solid brick. Use 0.01 opacity so it is’t noticeable by people, but are seen as opaque by the programming.

Doesn’t work, unfortunately. Tried it out earlier and hasn’t proven to be useful at all.

Which part doesn’t work? The opacity or the tech?

Regardless of both, it still adds a glow.

This may be a problem with how Roblox does lighting on materials. You can try, amongst other things, changing the material of the leaf mesh/part, changing lighting to Voxel or Compatibility (although not truly as realistic, it removes the shadows that may be causing that), or maybe changing the time-of-day (these glow effect things are usually determined partially from that).

I’m aware of the options you mentioned above but hate to utilise them as it, as you mentioned, ruins realism which I want to keep. I appreciate your reply but it unfortunately not what I am looking for.

You didn’t have your alpha channels right(so some parts that should be transparent aren’t), most likely when making the texture, you didn’t clear out all the unnecessary space. I suggest redoing the texture.

– Solution
Turn down game.Lighting.EnvironmentSpecularScale. This effect is causing your problem (because of your texture).

Good Luck,

1 Like

It is literally a tree with .pngs fro limbs. I would say that’s pretty unrealistic and lacks depth. Either build a tree and use shadowmap or future, or keep the current tree and switch to compatibility or voxel.

Incorrect; turning it down just slightly removes the blur but its still extremely noticeable.

I think I changed another setting too because I had gotten it to work. Let me try it out again when I can get back to my computer.

1 Like

Change the material of the leaves to concrete(or what ever works best for you) and turn down EnvironmentSpecularScale. I also changed a few lighting settings to make it look a bit lighter.

Here are the Lighting settings:

Here are the basepart settings:

Dev Forum 2

And here is the worst-case scenario: