How do I stop a BillboardGui from moving up whenever I walk away from it?

Hello,

I’m currently trying to create a BillboardGui that displays the current player’s name and health. However, whenever I walk away, it goes up and cuts off the frame. I’m using Scale to size my BillboardGui. The size is {4, 0}, {1, 0}, the StudsOffset is 0, 1.5, 0, and the max distance is 100. Is there any way to prevent this behavior?

Thanks,
p0s_0.

1 Like

If you’re talking about the billboard getting bigger the further you go away, theres a setting to turn that off though I forgot what it’s called but go into the billboard and check it’s properties and play around until it stops

1 Like

That’s not what I’m talking about.

what do you mean by the billboard going up then?

1 Like

Whenever I walk away, the frame goes up from the original position and cuts off the username and health.

can’t you lock it inplace in properties?

1 Like

Some times putting an offset to a BillBoardGui makes it move, use an attachment instead of adding offset

2 Likes

I just removed the offset and it still moves.

Which property is that? I didn’t see any option.

:frowning: I don’t know then got 0 clue

1 Like

You must have its parent be an attachment so that way, you can use that instead of offset

Also, Are you sure you disabled all the “Offset” settings?

2 Likes

I am sure that I disabled all the offset settings.

Do you have a video of the issue? I’d probably be better to visualize it

1 Like

Oh wait, I remember, It’s the position of the GUI under the billboard that might be doing that problem! You must keep it to {0,0}{0,0}

1 Like

I can’t record anything, my PC will lag like crazy.

Do you mean the Frame? The position is 0, 0, 0, 0.

Huh, Maybe check the things INSIDE that frame?

1 Like

There’s a frame that’s in the middle that has the position of {0.5, -51},{1, -49}, but the frame needs to be there.

Try changing its offset to

{1, 0}{1, 0}
1 Like

Which offset are you talking about?