How do I stop car wheels clipping into ground?

Hey this is my first time making a chassis for a vehicle,

The car is a model and is welded to a center part that is the size x and z wise of the car model itself, here’s what it looks like now:

Collisions on the wheels are on and the parts are Massless.

1 Like



Are the wheels CanCollide set to true?

Mark this post as solution if it solved your problem.

For some stupod reason I assumed that turning collisions on for the model would enable cancollide on all child parts, I realise now it’s only for PhysicsService touch events. Thanks :3