How do i stop it from stacking up? [ISSUE SOLVED]

Hello,

If I’m duplicating or copying and pasting it will keep stacking up

I still have colissions off but it still doesn’t work.
image

Thank you for reading.

[ISSUE SOLVED]

1 Like

What are the physics settings of this part? (CanCollide, CanTouch, CanQuery, Anchored, etc)

2 Likes

copy and pasting normally does that I’m pretty sure. Duplicating shouldn’t do that (idk what the issue is there). If you really want to make sure it doesn’t do that you might just have to copy the part, right click the workspace instance in Explorer and then left click the Paste into at Original Location.

Yes, that’s correct:

  • Pasting with Ctrl+V will always stack up the objects. I have to use “Paste at Original Location” to have them not stack up.

  • Duplicating with Ctrl+D uses the state of the Collisions toggle to decide whether the objects should stack up.

I just turned on some internal refactoring of these commands though, so something could be broken, hence why I posted here asking for details.

2 Likes

CanCollide: on
CanTouch: on
CanQuery: -
Anchored: no

Mode: Geometric
colissions: off
join surfaces: off

It happens to every object, regardless of whether any of these settings are turned on or off

Does it happen on a new empty baseplate?

Could you disable any plugins you have installed and try it again?

Yes it happens to every place

I disabled all plugins I have installed but it still doesn’t work

External Media

have you tried turning it off and turning it back on agian?

Its hard to tell from the video. Is you experence different from what is shown in this video?

I’ve tried turning it on and off, but it still doesn’t work as intended

the video has the same experience as me.

O! If your experence iss the exact same as in the cideo then your copy paste works as it should!! (im not quite sure why it stacks but as was prevsously stated, thats whats suposed to happen)

If you want it to not stack try using Ctrl+D to duplicate (the stacking should stop)

If i use Ctrl+D it still stacks

have you tried tuning CanCollide off?

Yes, i already tried turning CanCollide off.

Not sure why Ctrl+D doesn’t work for you, but just I use F3X’s cloning tool that essentially just clones in the exact same spot without any stacking, which I find pretty useful. If you wanna use it go ahead, but there’s probably a better solution that doesnt require you use a whole 'nother plugin.

also oh my god the lightmode flashbang bro :sob:

1 Like

Thank you for letting me know that, but yes I’d rather want the solution.

Could you DM me the place file so I can check that there isn’t something weird going on with the content? (File → Save to File to get a file)

1 Like