How do I stop the sky gradient from looking jittery?

Hello! I’m currently working on revising my skybox, and for some reason, these weird gradient lines keep popping up:

(I marked with black stripes to demonstrate the lines as much as I could)

How do I stop that from happening? Is it my display or? I’ve tried applying dither and setting it as a high quality pic (4k x 4k res)



This is called color banding. You can try removing it by blurring the image in a external program.

I have. I tried using Gaussian Blur and Radial Blur to no avail. This was done using


I saw that you already tried adding noise. Yeah I don’t know how to fix it in any other way.

I’m my opinion, I think it looks fine the way it is. Your average player won’t care about it.

1 Like

Colour-banding is caused by lower bit-depths in images.
Images on Roblox seem to be limited to 8-Bits of colour, meaning an image can only contain 16 million colours. PNGs and TIFs are capable of 16-Bit colour, or about 281 trillion colours.

In 8-Bit images the only way to avoid visible banding is by using dithering. Blurring your image will have no effect on a regular 8-bit export.


Here is a gradient I created in photopea:

If we apply a posterize filter to the image we can see that the transition from one shade of blue to the other is a solid line.


If we now re-create the gradient but with the dither option enabled

Then our final gradient will look like this with the posterize filter:
And without the posterize filter:

The only issue I can foresee is that any compression on the image will interfere with the effect, this may be the issue you’re running into. Secondly, Roblox only accepts 1k images at the moment so uploading as 4k will have little effect.

Double-check that the image looks good before you upload it to roblox. If it’s bad, then the chances are you may be doing something wrong with the dithering.

Hope this helps.

1 Like

Hi! Thanks for your concern. I have tried dithering the image as well. It looks pretty good:

I’m not sure what else to do. I’ve done everything you’ve said.

I think the reason it’s doing that is because of the compression.