How do i stop this from happening?

you see how it goes black towards the end

Could you be more specific about what you mean?

You see on the left white mesh at the end when it is meeting with the new mesh it looks as if there is a shadow but there is no shadow on the mesh itself

1 Like

Roblox bugs probably

I love roblox omg ahhh

Try setting the CastShadow property to false on the mesh it may help with the specific area.

1 Like

That is not really a roblox problem. That is happening because the model does not have good topology.