How do I stretch GUIs past the Top Bar?

I am developing a game alongside my colleague, and we’re needing help regarding GUIs in Studio.
I am not the scripter for this project, my colleague is. But considering he isn’t in the DevForum, I am posting this thread and will pass on any appropriate responses to him.

When the player joins our game, they’re greeted with the menu screen. Our aim is to have the menu screen UI take up the whole screen, but the top bar is preventing us from doing that.

This is what the menu screen UI currently looks like:

Don’t mind the white rectangle covering part of the UI, that is only there to cover the game’s logo/name as that is classified information for now.
Our problem though, is that we’re not sure how to stretch the UI up so it passes the top bar and covers the whole screen.

We aim to have our menu screen look like this:

As you can see with this menu screen, the UI stretches beyond the top bar and therefore covers the whole screen, which as I stated is what my colleague and I are trying to achieve.

Any responses that can aid my colleague and I in knowing how to achieve this, would be much appreciated. Thank you!


Hello. To do this you have to set the object position to a negative Y Scale. ({0, 0},{-0.1, 0}).
And that’s all.


To make your GUI cover the entire screen, refer to this page: IgnoreUiInset

Disabling the top bar can be found on this post


Adding onto what @SFranxisco said, if you want to hide the topbar ingame but not remove any core elements you can do this



Another thing that might help is usually when you have a GUI going over the top bar it appears darker than the rest of the UI because of the grey in the top bar mixing with the colour of your GUI:

.To fix this you can remove/ disable the top bar by using the script see in this :Hidable Topbar!


Just saw that this point was already made. Sorry for repeating but I still hope it helps.

Awesome it works, thanks!


I don’t know how to do this, I wrote this code and it doesn’t recognize it as a property:

local StarterGui = game:GetService("StarterGui")
StarterGui.IgnoreGuiInset = true


it is not a property of startergui, it is a property of your screengui

1 Like

Just click on your screengui and tick this



That doesn’t work for me. Which is quite annoying. do you know what I can do to fix this???

1 Like

Read what I just said to him. You click on the gui and tick ignoreguinset

1 Like