How Do You Stop Level of Detail (Graphics Level) Affecting Particles?

Hi, I’ve been trying to learn to make particles, and an issue I’m running into is having lower levels of detail making the particles rate basically nothing. On graphics level 10, it looks really good, but only 1, it looks garbage. I know this is to help performance, but I can easily make my particles optimised myself rather than relying on Roblox. If I can’t do anything in the particle settings themselves to solve this, is there a way to edit the actual code of the rendering to change it?

No, if you really want you could code your own particles with billboard gui, but that would be a waste of performance.

If the user already can’t afford graphic lvl 10, it’ll make things worse.

The only way for this - set particles Rate locally on client, based on their quality level. Lower level of detail - higher rate, and vise versa.
link, which shows player settings article