How to change graphics settings in Studio in Run Mode

Hi,

I’m currently testing my game in Studio. When testing in Studio, I can choose “Play”, “Play Here” and “Run”. When I choose the first two options, I can adjust the graphic settings via the in game menu. I want to adjust the graphics settings while in “Run” mode. However, I do not see a way to do this. It looks like the graphics setting is defaulting to “Automatic”. Because of this the water doesn’t look as realistic. I’m creating screen shots for the game and I want to adjust the realism higher. I want to create the screen shots in Run mode, so I can place the camera where I want and there is no avatar in the shot.

Thanks,
Leif_aw

1 Like

Hello,

  1. Open Studio Settings: Click on File > Studio Settings or press Alt+S.
  2. Change Quality Level:
    • Go to Rendering.
    • Select Editor Quality Level.
    • Choose your desired level.
  • Accessing Settings:

  • Adjusting Quality:

Hope this helps :slight_smile:
CrazySnoopylove

3 Likes

You can go free cam in Play or Play here by pressing ctrl or shift or both (I can’t remember the exact sequence) then P.
This allows you to move the camera wherever you want it.

@CrazySnoopylove does that work when testing in Run mode though?

2 Likes

To clarify, the shortcut for activating the free camera in Play or Play Here mode is indeed Shift + P. It’s a handy feature for navigating the scene more freely.

Regarding your question about testing in Run mode, the free camera functionality works similarly. However, it’s worth noting that Roblox Studio defaults to lower graphics settings during development and testing for performance reasons. If you’re looking to enhance the visual quality while testing, adjusting the Editor Quality Level in Studio Settings can really make a difference. It allows you to test your game under conditions closer to what players might experience, depending on their settings.

3 Likes

Thanks Crazy Snoopylove! Your information was very helpful! I was able to take my screenshots.

Leif_aw

1 Like

Thanks Scottifly! I wasn’t aware of this feature

Leif_aw

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.