How to disable editing SurfaceGui Text objects in the 3D view

Recently I have noticed that if I attempt to click on a part that contains a SurfaceGui object with a TextLabel rather than the original and expected behaviour of selecting the part so I can drag it about. The text now disappears and my keyboard inputs are redirected into editing the text. Is there a way to disable this and when was this introduced? I have already tried poking through studio settings but I can’t find anything that would match the description of this issue.

1 Like

This sounds like a bug since when I last checked it didn’t behave this way. I think the UI selection should be removed entirely because it does not help scale or position UI elements at all and the proper way to do so is manually in the properties window.

Also another thing I’ve noticed now that even IN LIVE GAMES I can just click on most TextLabels and it will just let me change them. Idk if it is only visible on my client or if it replicates to others.

Very interesting. Can you show a video of this?