How to disable the Roblox Desktop app (Windows Only)

Ok so personally I don’t like the new Roblox desktop app and I couldn’t find any guides on how to disable it so I decided to write my own. Enjoy!

Save the following as a .ps1 file (Credits to @pobammer for making this)

$Key = "HKCU:\Software\ROBLOX Corporation\Environments\roblox-player"
while ($true)
{
	$CurrentValue = (Get-ItemProperty -Path $Key -Name "LaunchExp").LaunchExp
	if ($CurrentValue -eq "InApp")
	{
		#Write-Output "Value is InApp."
		Set-ItemProperty -Path $Key -Name "LaunchExp" -Value "InBrowser"
	}

	Start-Sleep -Milliseconds 50
}

Just save it on your desktop or put it in your startup folder (so it runs when you login).
Opening startup folder: Press WIN + R type “shell:startup” and press enter.

As Roblox now force enables desktop mode, this was edited to include the file above. I have left the original tutorial below for anyone interested

Disabling the desktop app requires you to use regedit. If you don’t know what your doing only touch the registry I have shown

Step 1: Opening regedit.exe
If you don’t know how to open regedit then follow microsoft’s official guide (there is also a warning about regedit from microsoft there, which I urge you to read).

Step 2: Navigating to the Roblox registry
image
Either paste in the following path at the top or manually find your way there.
Computer\HKEY_CURRENT_USER\SOFTWARE\ROBLOX Corporation\Environments\roblox-player

Step 3: Disabling the Desktop App
image
Right click the registry named “LaunchExp”, press Modify and change the value from “InApp” to “InBrowser”. Once you press Ok it will automatically save. If you ever want to enable the desktop app again then change the value back to “InApp”.

Thank you for reading. If this was helpful please leave a like :slight_smile:

185 Likes

Thank you for this, I hated it and I am glad someone knew a solution on how to revert it.

13 Likes

Thank you, now i dont have to get trapped in Roblox.

11 Likes

There’s a much simpler way of doing this.

You could just go to settings in the desktop app and click “Opt-Out.

9 Likes

hey this can help me to make it do the exact opposite since i actually like it lol

3 Likes

i went to settings, theres no option for me to opt out of it

besides like 7 months ago or something i already opted out of it dont know why they forced it this time

13 Likes

You are literally a god. Thank you!

4 Likes

Yeah. For me, it isn’t there either. I think the desktop app is “out of beta” now.

4 Likes

it worked for me tysm
this browser app is really bad, i don’t know who thought it would be a good idea to force everyone to use it

6 Likes

Sadly they removed the opt-out button.

4 Likes

(I just realised you weren’t asking for help lol, my bad. I’ll leave it here anyway so if anyone does need it then they don’t have to ask)

I don’t know if it depends on your location but I know that at the moment in the UK there should be a button at the top of the home page that lets you enable the desktop app.
image

If not then follow the tutorial and set the registry value to “InApp”. If the value doesn’t exist then try making one (if you don’t know how to do that then just right-click in the empty space below the other registries on the right and make a new string value called “LaunchExp”)
image

8 Likes

Funnily enough, on my desktop I didn’t have the option to opt-out; I had to create a new account in the app, log-in to it, then navigate to the settings in order to see the opt-out. It wouldn’t show me the opt-out on my main account. Not only that, ever since the app installed itself, I’ve had frequent crashes. Hell, even clicking log-out on my desktop on my main account crashed the program!

On my laptop, I tried to do the same method as before however clicking the opt-out button did nothing. Nothing happened at all.

Thankfully I managed to find this thread. Saved me from malding because of this unnecessary, unoptimized and unwanted program.

@Paracolax Thank you for this, it really helped. :slight_smile:

6 Likes

Thanks! I got the beta app, and this helped me disable it.

5 Likes

Thank you for the helpful tutorial, it really helps me a lot. Recently, Roblox has updated and is wanting me to use the app instead of the browser version which in my opinion, honestly sucks. Although while I was scrolling down through the dev forum, I stumbled upon this informative post tutorial, which really helped me get rid of the app for good. Thanks for the tutorial, it’s really well explained and straight to the point. :happy1:

2 Likes

thank you for this. My client has not only been awful as a power user, but it was slowing my game down exponentially on my windows 11 2021 Razer Blade Stealth.

3 Likes

There’s an easier, less dangerous way.

Simply go into Settings and then disable beta. Lol

1 Like

What is that OS lol. Roblox doesn’t support windows 11 bootlegs

1 Like

It wasn’t an option at the time

2 Likes

Well it is now, so change, delete, or note this in your topic.

1 Like

new question how to enable (i cant see open popups)

1 Like