How to fix Level of Detail on Roblox Studio

All of my settings are maxxed, however my friend and I’s viewports show completely different things.

Fixed via setting MeshDetail in settings to DistanceBased? Even though I had it on 4 regardless.

Mine:

Friends:

Settings:

Is it different on different angles or no?

It’s like that from every angle, yes.

Did you try un-installing an reinstalling Roblox studio?

Fixed by setting MeshDetail to DistanceBased instead of Level04 (which in my eyes should work anyways?)