How to fix mesh transparency?

I am attempting to make a glass in Blender and then import it into Studio however I find that whenever I change the transparency of the part, it justs becomes messy like this…

image image

Can someone help me with a solution whether through Blender or Studio? Thanks


I am no blender expert, but I’m pretty sure it’s because there are faces inside the cup making it so that u see those and the outside of the cup. There for making it look weird.

1 Like

You need to normalize the solids, and add a solidify modifier.


I had this issue probably like a week ago and found a solution the only way to fix this at the moment that I know is through blender. You have to go to blender face orientations. Then if the top part of the cup shows red you have to select everything and flip it. I didn’t explain it with details but here is a video to explain it better. Also if the video still doesn’t solve the problem you may have to extrude the part from it being so thin and not having another face

1 Like

The normals in that area may be flipped the other way, causing it to make a transparency effect. I’ll link a video below on how to flip normals!


1 Like

You could just enable DoubleSided of the mesh, by the way.

1 Like

DoubleSided didn’t come out till months later (I believe?).

But also this would be a terrible idea performance wise. It’d fix the issue but it’s a lazy and laggy way of fixing something so simple.

Do not enable DoubleSided because you don’t know how to flip normals in Blender, learning will save your game from potential render lag. (Higher poly MeshParts with DoubleSided will cause more lag)

1 Like

Thank you guys for the concern. I can’t believe it’s been a year. Wow. I did manage to fix it of course. :joy:

1 Like

how you fixed it ?
i m having a issue like that with my mesh

1 Like