How to fix mtl file not working?

Hello developer forum! I was recently making a GFX for my friend, in the process of rigging and setting everything up I encountered an issue. When I try to add in the mtl file by selecting the head, the file doesn’t show up even though I saved it in downloads. Anyway to fix this?

-Thank you in advance, Jarix46

Could you send a screenshot or video of what you are doing when saving it as a file?

Then I put it into downloads, and I search for it in downloads in blender yet it still doesn’t work

Try looking at your recents and 3d models folder if its not there, maybe try saving it as a file and using that, I don’t know if that will work though.

Open your files app. It may be there.

Ok, I was able to find it. But I don’t know why it became a png all of a sudden. I might have to contact Blender support

You found it in your files or blender? Did you export a decal on accident?

In blender, all of my issues have been trying to find the file. And I’ve already found it, but for some reason it turned my mtl file into a png. I tried searching up how to fix this and nothing gives

Hey there I’m having the same issue here. Do you have a solution to this?