How to I make 2 objects flush?

Hey Devs,

I’m having an issue with making 2 long parts stay flush against each other. I have the “Join Surfaces” option on and it makes a white outline on the surface of the side that’s touching the other object. But when I stretch one of the parts out it leaves a gap on one side and the other side is going right through. So, how do we go about fixing this?

Join Surfaces relates to welding objects, not alignment, and is likely the source of your issue.

It’s been doing the same thing before trying it as well, therefore no.

Are you perhaps looking for the “Collisions” checkbox instead? Making parts stay flush is just a matter of their position and size, no real trick to it.

Ive tried tinkering around with collisions, it doesn’t seem to change the issue.

I’m lead to believe that the model which is a house is causing the issue. I turned the entire house so that I could get the view from one of the windows which offset everything such as the rotation feature.
Its quite difficult to explain…

Well, when I run into issues with small gaps that I can’t easily fix I generally fall back onto this plugin: Stravant - ResizeAlign - Roblox
The “extend upto” option in particular is what you’d use for this case.