How To Import Blender Animations Using Skinned Meshes With Custom Avatars

This post literally answered all my question about blender animations with my mesh. holy damn TY!

2 Likes

So, I just came across a problem. When I import my animation into roblox, only 2 keyframes get imported, and they’re both the same…I exported correctly tho. I selected my aramature and mesh, exported as fbx, made sure it was only selected objects and that the scale was 0.01, I clicked the correct file, and yet 2 keyframes…weird

somehow I solved my problem by selecting the children of the armature along with the armature and the mesh itself…any explanation for why I wasn’t able to just select the armature and the mesh itself when exporting?

1 Like

That’s strange, it might be possible that it only imported the children you had selected if you only had some. Otherwise I’m not sure what would have caused it.

There’s some weird things going on in non-linear animation in blender, something we typically don’t check before exporting. What you SHOULD see is one animation under armature, the one animation you are looking to load with your export fbx. What can happen is that animation gets stored under a part (which is parented to the armature). If you don’t select the part that has the animation, there is no animation.

What you also don’t want is dozens of animations showing. That can cause distortions as Roblox and blender try to mush it all together. In the picture below, the camera has a second action. I don’t export the camera, so there’s no conflict.

image

The last advice I can give is to name the animation/action you are trying to export something that shows up alphabetically first. I add “aa” to the name of the action. I have pretty good luck with this.

2 Likes

I did everything, but at the end, when trying to import the animation itself, I get this in the animation editor.
image
When I play it, nothing happens.

I tried putting the model’s position to 0,0,0

But that didn’t work.

Send a picture of exactly what you are exporting. Depending on how you did the animation, you may have to have certain things selected in the animation editor while you are exporting.

I fixed it, I think the problem was that NLA Strips were not turned on.
Thanks for the help :slight_smile:

1 Like

I ran into another problem, when trying to import the wings one at a time into roblox, the right wing is messed up.


But if I import both wings with their bones at the same time, the right wing doesn’t have any of its bones.
image
Also, when I import the wings in the same FBX file, they overlap each other at first, the picture on top is what you see when I move one of the wings to the side
image

I did not use a mirror modifier for the wings, I used CTRL + M to mirror.
The properties of the exports are the same for both wings.


I also tried opening my right wing inside of 3d viewer, and everything is fine.

Thanks :slight_smile:

You used a mirror modifier on the wings, but did you mirror the rig? There are certain rig properties that do not translate to FBX. I always accept my mirror modifiers before exporting (I recommending making a backup file)

3 Likes

Like @GolgiToad said, make sure you apply all transforms and modifiers. Also make sure to mirror the rig as well as the model and re-parent the rig to the model.

I tried using a mirror modifier and applying the changes, but when applied, the mirror modifier is different from what it looked like before applied.

Looks like you have some unapplied rotations as well. for example, you rotated it 90, mirrored on the X (but visually it looks like it is rotated on the Y) axis, accepted, then it got rotated again (because the mirror didn’t exist until you applied the modifier).

Accept the rotation, fix the modifier to mirror on the Y, not X, and then try applying the mirror.

I tried applying the rotation with CTRL + A, but it still does the same thing. Also, the mirror modifier is mirrored around a certain part of the dragon, not around the object’s origin.

OK, that was a good step to check. For comparison, I do the mirror first, then armature on my meshes. Might make a difference? It didn’t for me.

It almost has to be the armature now, but debugging that is tricky. What does your mirrored wing look like without visual representation of the armature? Turn this off.

To fix the armature, it might be a matter of removing the armature, accepting the mirror, then re-applying the armature. It might be an issue of vertex groups not being properly mirrored.

The good news is I found at one model of mine where I never accepted the mirror on the mesh. I did accept the mirrored bones and did extra vertex work to get that model functional. So it might be the final fix allows you to import both wings as a single model. It’s not impossible!

This is what it looks like when I turn it off.


I tried removing the armature modifier, and adding a mirror modifier and applying it, and then adding the armature modifier again, but it messed up the mesh again.

I think that solves it, actually. When you add the armature modifier fresh, the only thing that should move the mesh is existing vertex groups.

Here’s how you check that:

In Weight Paint mode, pick a vertex group that should be for one wing. We will use my rat’s ear as an example. Only one ear is red (skinned to the RatEar_R bone).

Similarly, the other ear:

If both ears are mapped to the same bone, things break fast. If the bone has moved from the vertices it was set to manipulate, everything shifts. The trick here, the left ear does not exist. It’s still a mirror. I instead mirrored the vertex groups under “Data.” There are special naming rules for mirroring. (_R and _L worked for me)


bones - Armature rotates both sides of mirrored mesh - Blender Stack Exchange

If this still doesn’t work or you need help figuring out the vertex groups, I’ll happily help you continue debugging in messages. Let me know!