How To Import Blender Animations Using Skinned Meshes With Custom Avatars

Though there are plugins around for animating roblox standard rigs in blender, there are none for skinned meshes. Here I will be showing you the steps to do this and some common bugs and fixes

Step 1
Load in your .blend file and animate how you would in any case using blender.

Step 2
Export the file as an FBX.


Step 3
Load up roblox studio and import the FBX as custom avatar using the avatar importer plugin that comes with studio.


Step 4
Scale your model to its correct size and import the FBX animation. This is the same file as you used to import the model.


Step 5
Make sure everything is working right when you play the animation. If you encounter a bug where the mesh basically turns in to a blobs scroll down to the common bugs section of this post to see how to fix that.


Step 6
Save and name your animation then publish the game to make sure you don’t lose your progress.


End

The Mesh Blob Bug

Cause
For some reason, the bones in a skinned mesh do not work properly when the mesh is at its original size or a bit above it, forcing you to scale it up. This could be a problem since you might need to scale it up more than it should be to fit your game properly.

Note: This bug is patched for the most part in newer versions of studio but it is still possible to encounter.

Solution

Step 1
Before you export your mesh from blender as an FBX, scale the entire mesh and armature to the point where it is hard to zoom in on without using one of the orthographic views.


Step 2
Follow the original steps from the main section of this tutorial until you import it to studio.

Step 3
Scale the model up to the size you want it.


Step 4
The bug should be fixed now, continue on with the tutorial as normal.

That’s all! If you enjoyed or have any problems make sure to comment your questions and other feedback. Thank’s for reading

53 Likes

I spent 4 hours trying to figure this out, and bam you post how to do it. Thank you so much! Greatly appreciated. :smiley:

5 Likes

Good tutorial, however, I feel like it could be expanded with a “how to rig” section.

1 Like

I would but there are a lot of tutorials already out there for that. Would it be helpful if I linked one of those?

1 Like

I agree that there are many of them, however, they’re not on the DevForum (unless I am blind, oof). It’d be a lot more productive for those who want to start with skinned meshes.

1 Like

I’ll make another tutorial for that.

4 Likes

Sorry for the bump, does anyone know how to fix keys being misaligned? When I import my animation i get a warning that my keys are misaligned, and even if I align them (as I am prompted to) my animation will be out of sync: when it loops around, it snaps in place.

1 Like

I’m seeing the same problem. No fix found yet.

1 Like

I agree bu6i like the to the point topic. Maybe some other kind soul would. I rig fine in blender but transferring here is harder. That plugin seemed off

In blender you can move timeline to start and end at specific frames.

For examply running animation had that snap.

I had to start it at about frame 4 and end different as well

First of all, thank you for responding to something from the start of this year.

Secondly, what?

Basically the timeline has the play button but it’s pulled down by default pull it up you select animation having trouble with skipping and try changing the start and end keyframes in that window playing animation until it’s ‘tuned’ right.smooth.
The animation can end at a point in cycle that fits better

I got no clue what you’re talking about man. My original response was meant as feedback to the OP. If you’re using a translator, I suggest switching it to something better.

Sorry for no response, I just got back from a 2 month break and haven’t been on at all. I’ll look in to this later if you still need a solution.

1 Like

I’ve somehow fixed it and saved my export settings to a profile, no idea what setting exactly fixed it tho.

1 Like

I’ve always wondered how people do this but never tried since I haven’t needed to yet, but now I know! Thank you

I have learned at least “why” it’s happening. In my case, I am creating a 24 fps animation, exactly 24 frames long. The animation editor puts them in frames 0 through 23, and assumes it’s a 23 fps animation. Since the animation editor saves every keyframe at a point in time (and not frame #), everything gets misaligned by some weird fraction of 23.

I am able to manipulate this with a self-built plug in, but it’s not really that important for me yet. I haven’t gotten far enough to care about 1 frame.

To fix that all you should have to do is move the frames up 1 and change it to 25 frames in blender. Really it’s just an issue with studios capabilities in importing from external programs.

1 Like

Ahh, the end frame. I only use that for loops. Makes sense.

There is so much wrong with the animation importer, and some of it has to do with the blender exporter. I should probably learn the FBX file format and make my own.

2 Likes

That’d be pretty neat. Make sure to let me know if that happens.

1 Like