How to make a texture be noticable

I’ve been trying to add textures to my game but every time I do, either the color isn’t the color I want and I can’t change it or the design doesn’t show clearly enough.
Ive been using

I’ve been trying to test them out on tester blocks like MeshParts with SufficeAppearance or a Part with Texture then with SufficeAppearance.



You can see that I put the Roughness in the MetalnessMap because I needed to add the Meatelness in the ColorMop to give it the look it needed. But right when I did that the color was only white and when I tried coloring it, it didn’t let me. So I took out the ColorMap and put everything where it belonged and left the ColorMap empty. And when I went to color the part it just looked like a plastic wall.

I’ve tried to use videos but half of them are by using Decals from google images and others were explaining the problem I was going through, or aren’t explaining what to download for each of the parts or what to put in the ColorMap.


Not exactly sure if this is a factor that would affect it, but what Lighting Technology are you using?

I don’t know what that is but this is how it looks like in came compared to the RobloxStudios Cement

the left is the textured cement and the right is the in-game texture.

Select Lighting in your Explorer window, then click the drop-down next to Technology. There will be the 4 choices shown on the link. Try each one out to see if it renders differently.

When i clicked on each of then they just made the lights go to a blinding state and didn’t change the look of the wall

But which one of the Technologies are you using right now?

And what is your Lighting Brightness Property set to?
If it’s too high it may be washing out your textures.

My brightness is at 0.41 and I’m using Compactibility

Pbr textures don’t work with artificial lighting (substance lighting or point of light) unless you turn on future lighting

I turned it on and this is how it ends up looking

it’s a little not pleasing

This works for me when I use the material editor or whatever it’s called. Should replace where the normal material changer is in the home tab.