How to make all the script editor text bold?

Hello, I want to make all the script editor font be bold and not make it like a word has it bold and another doesn’t have it bold, can you help me please? Thanks!

(I don’t know if this is the right category for asking this question.)

Not sure if this is the right category either, but you can do that in the settings.

Open Roblox Studio → File → Studio Settings → Studio and you’ll find ScriptEditor settings on the right pane. Scroll down and you’ll see Font. Click font and change normal to bold.


It is not working, all my fonts are still like the normal font… Here’s the image of my properties:

Did you try restarting studio?

1 Like

No, let me try restarting studio then I will tell you if it worked.

It didn’t work, sadly, is there any way to fix this problem?

Looks like the studio editor doesn’t care if you set bold or not in that setting. Unless there’s some other hacky way of doing it or a hidden setting, I don’t see anything to do what you want.

If you want, you can do what many people do now-a-days. They use external text editors like visual studio code to edit lua scripts. Maybe look into that?

1 Like

Do you mean Rojo? I sometimes use it, but it’s hard for me to use it becuase I can’t link all the parts in the Workspace, I mean like there are no folders, or scripts that are inside of parts, you know what I mean?

1 Like

You can use CollectionService to link the parts. It is really useful.

1 Like

Then, it will show it on Rojo orr?

Oh, do you mean the placeholder when you press ctrl + space?

Wait no, that was what I was finding, thank you for helping!

1 Like