How to make character collide false?

I tried to make character not collideable but still my character was colliding with other objects. Is there any way to make it so it doesn’t collide like in Tower Defense Simulator and Tower Battles? sorry if this is badly formated but I made this post on phone


Take a look at this:

It may be helpful haha.


Question’s already been answered, but anyway:
ROBLOX defaults the Player’s character’s parts to enable the CanCollide boolean whenever the parts do not have CanCollide enabled (except for arms), which explains why one for loop didn’t work for you. They most likely did this because trying to disable the CanCollide using a loop ends up making your character fall through everything, including the floor. Thankfully, there’s CollisionGroups and such to fix this, as @Paralusuz has linked.

1 Like

Only the Head, Torso and HumanoidRootPart of any rig have collisions enabled. These are hacked to true every frame rather than every change. This is done for the sake of collisions, physics and downcasting (the Humanoid does not walk based on collisions, believe it or not, it’s actually a floating entity).