How to make the water clear in studio?

So, the title says it all.

In the normal game it looks like this:
image

But in studio it looks like this:

How can I change this?

Have you tried changing your Studio Graphics setting? I believe it goes to 21 or 22.

It’s set as 21.

did you get that water from the toolbox?

Sadly, that’s just how studio water works. You have to go in the client for the water affects to show.

1 Like

He can change is studio graphics to make it clear I believe he got that water from the toolbox its really square.

You can’t get water from a toolbox. The only way you can generate it is by going into the terrain tools.

It depends on your graphics quality, higher graphics makes water clear

As @Crazedbrick1 said, studio water just looks like that regardless of settings.

Change your graphics settings to max in both, roblox studio & roblox game. Go to the terrain part, the water settings and change the transparency to the most invisible type number. That’ll work!

3 Likes

I used the terrain converter. Converted the baseplate to water.

There is a way to see water clearly in studio.


Look at this image. Clearly, the water is transparent.

How? Follow these steps.

  1. Hit Alt + S. The following should pop up:

image

  1. Notice the highlighted section. Click on the box to open up a drop-down, and set the value to a high number like 21.

Make sure you select Edit Quality Level and not Quality Level.

image

  1. Hit “Close” and watch as water turns transparent.

Why does this work? Roblox Studio by default will place you on a lower Edit Quality Level so Studio runs smoothly. Doing this will make Studio run slower, but it will look nicer.

On Edit Quality Level 1 it looks like this:

The water is no longer transparent.


These users are correct.

Square terrain can easily be made with a number of tools including Replace, Generate, Add, Sea Level, Part to Terrain, and many other methods not listed.

Incorrect. Water can be created from a script you got from the toolbox, among other methods.

There is no such thing as a “Terrain Part.” You can change water transparency under Terrain’s properties. Be sure to set the number to 1 to get the most transparent water possible.

This is a post about water transparency in Studio, not in game. Those two aren’t related, you won’t get clear water in studio because you played the game on the engine.

Perhaps you set “Quality Level” to 21 instead of “Edit Quality Level?” Please double check your settings.

Hope this helped you, @Aiden_12114.

5 Likes

That’s false actually. The toolbox(A simple script) allows you to generate terrain water without actually having to open up terrain tools.

All my settings are at max and the water still looks like that. What’s your specs?

You also need to change the water transparency

Yes, like @ImTheBuildGuy said, its true that it actually depends on your graphics settings that you are currently using.

Guess that a better graphics settings of equipment will do

About the water transparency, turning it down to the lowest of all will make the best effect and cleaniness of the water

If you want it clear then you could always make it a brick that’s clear with collisions off but there won’t be any swimming animation and you will be standing.