How to Prevent Light from Bleeding through walls


I’m making a lighting system for my game, and I need to use pointlight in order to get the appropriate amount of brightness in the building. The problem with pointlight is that without turning on shadows, the light bleeds through the roof and walls. However, if I turn on shadows, the building becomes too dark and looks weird.

My question = Is there a way to stop light from bleeding through the walls and roof without turning shadows on?

1 Like

There’s a option on lighting called “Shadows” or something like that, active it. (It’s the only way sadly)

(if you want more light inside, put lower lights inside)

One thing you can try to help out a little bit is moving your light source so that it isn’t clipping into the ceiling. If your light fixtures are meant to look like they’re on the ceiling, just make those not emit light and have an invisible part that emits light just below the ceiling. Here’s a basic demonstration showing the slight difference it can make.

Light clipping into ceiling:

Light not clipping into ceiling:

If you need to make the room look even more well lit, you can make your walls two parts thick, and disable CastShadows on the inner walls - this makes the room appear even more well lit, while also (thanks to the outer walls) prevents the light from bleeding out of the room. Here’s what it looks like:

Hope this can help you!

1 Like