How to prevent the player from automatically jumping on a slope part

Hello, I would like to know how to prevent the player to jump automatically when he is on a slope part.

On some games especially obby like Tower of Hell or some Difficult Chart the developer made sure that the players don’t jump automatically when they touch parts that are sloping, unfortunately I don’t know how they do this maneuver. I tried to modify the physics of the parts but without success. If anyone can help me ? I hope you will understand what i mean (i’m french speaker, my english is not very well)

Thanks

1 Like

I specify that this problem does not appear on the games while being on computer, it appears only while playing on mobile

did u try to set the jump power or jump height to 0?

hello, the problem appears when the player tries to climb a part like this

If i set the jump to 0 then the player won’t able to jump anymore ?

ok so u can cast a ray in the - top direction of the players root

so it will be like a only sound script but instead of changing music u will be changing the jumpower

I’m not sure if this is what you’re asking for, but if you want to disable autojumping for mobile you can by going to StarterPlayer, scrolling to the bottom and unchecking the AutoJumpEnabled property.
image

3 Likes

I’m sure there must be a way to do this without changing the jump power, which would be a big problem for obby

Thank you i’m going to try character

Thank you it was that, nice !

Characters

1 Like