How to stop player flinging when falling from tall heights?

Hi! So I have a game similar to bubble gum sim where you jump clouds to get to new islands. However, when you fall sometimes you get flinged on a corner? Sometimes, it is severe and sometimes it is more subtle but still annoying. I have already tried disabling ragdoll but it doesn’t work?How can I fix this?

robloxapp-20210315-2035587.wmv (1.6 MB)

Local Script:

local char = script.Parent
local humanoid = char:WaitForChild("Humanoid")
local humanoidRootPart = char:WaitForChild("HumanoidRootPart")

local ragdoll = Enum.HumanoidStateType.Ragdoll
humanoid:SetStateEnabled(ragdoll, false)

Can I reupload this question as no one is seeing it?

Maybe this one?

humanoid:SetStateEnabled(Enum.HumanoidStateType.Ragdoll, false)

Hi, If you have read my code, I have already disabled ragdolls. But thanks for answering anyway

Sorry, I couldn’t see this one.

Is your local script in StarterPlayer > StarterCharacterScripts?

Yes, it is. I did local char = script.Parent

Have you tried making the set state server-sided or looping it?

Uhm no? I have not looped it or anything

If it is client sided (local script) then try this

while humanoid ~= nil do
humanoid:SetStateEnabled(ragdoll, false)