How to stop SurfaceGui clipping through parts?


I’ve got a SurfaceGui hiding behind this grey part here:
This is meant to be like those split flap/Solari displays, where the letters flip around, except there would only be one moving part per letter to reduce part count and lag. In this case, the grey part would flip down to reveal the next letter, then immediately be placed back up to the top and flip over for the next letter, etc.

However, when you get just a few studs away (about 10), the letter begins to clip through the part
Any ideas how to either fix this or different ways to achieve the same effect without this clipping happening?

As a note, I can’t just hide the character that’s clipping through until the flap starts moving, as as soon as it starts moving the character needs to be visible, which would create a horrible flickering effect.

A few options:

  1. If the part overlapping the text is going to have another SurfaceGui on it, it will always be on top.
  2. Scale the part with the letter on it to half its size, and scale the TextLabel vertically by 2 so that the top half of the label cuts off. If you want, you could duplicate the object without the GUI and stack it to make it the same size (image below).


  1. If you really wanted to, I guess you could have a frame with the same background color as the overlapping part that covers the top half of the part with the letter on it. If you do this and don’t have another GUI on top, I would recommend making the overlapping part’s material smooth plastic, as otherwise, the overlap will be noticeable at a distance.

I would only recommend the first two options, but #3 is still possible (to my knowledge, there is no proper way to do this, but if someone else knows a way, please correct me).

1 Like