How would I make the wall lighting blend?

Does anyone know why the corners of this house have a dark ceiling, but gradient white down to black walls?

I have enabled the “Future” lighting technology, and have every part casting shadows. The ClockTime in Lighting is set to 0, and I would like to make this a spooky night-time scene.

Basically, I am trying to get every area to be dark, and I need help on figuring out why the top of the walls are not dark, though the ceiling is.

I cannot find any solutions for this unwanted happening, therefore I am considering it may be a Roblox Studio bug.


I would recommend scaling the roof upwards so that it creates a larger shadow on the inside.

That does not seem to have much of an effect, until I scale the roof upward enough to make the original design look awkward… :\

In the lighting service, you can specify the color of your shadows. Maybe your problem has something to do with that?

1 Like

Maybe your problem is solved by going to the properties and deactivating castshadow, I hope it works for you

1 Like

Maybe a bit of a bandage solution, but you could create a simple large box around your building that stops most light.


I don’t think that disabling shadows works for making shadows.

I could try this, if only I did not need a skybox to be relevant in my design, sorry.

1 Like

I wouldn’t recommend using future lighting at the moment since a lot of the cool effects like the pointlight shadows aren’t actually visible in game and only visible in studio

Just try switching back to shadowmap and see if it fixes your shadows

I tried replicating your situation as much as possible, and the only way I could make the lights disappear was by making the OutdoorAmbient darker. Unless your current OutdoorAmbient setting is integral to the build, I’d say turning that down a bit is the way to go

Roblox’s current jurassic voxel lighting uses 4x4 stud voxels, which means you have to make your walls at least 4 studs thick to fix this problem. You could try putting the brightness to 0 though, if you’re aiming for a night scene with no shadows.

Your problem is caused by Roblox shadows not working properly. You have done everything right, this one is on Roblox.

It has the same shadow effect as “Future” as I do not have any added lighting.

The OutdoorAmbient color value is at: 0,0,0.

The point is I want the shadows to stand out. The design would be flawed if the walls were four studs, sorry.

Go to Lighting > Properties > And then check the Shadows box.

If that is already enabled or it doesn’t work and you have parts in your game that emit light, then enable the shadows on it. Same steps as the ones mentioned before.

That probably won’t fix it… The problem is roblox’s builtin sunlight. I had the same problem with a dark corridor I built.

I agree, and think this is a possibility for an answer… :\

1 Like

I have all of that already active… :pensive: