HTTP 400 Bad Request when uploading images that are too big

When I try to upload decals or icons that are too large in terms of file size, the website will send me to a 400 page.

This doesn’t make it immediately clear to me that the image I’m trying to upload has a file size that is too large. The expected behavior is an error message that tells me the problem with what I’m uploading. Because this did not happen, I needed to waste time trying to debug the problem.

I ran into this bug today when I tried to upload some decals, but it has been happening for a long time.

You can reproduce this issue by generating a 5k x 5k px image full of noise and attempting to upload it, or using another image file of large size (12+ MB?).

After trying to upload

After pressing back (it redirects almost immediately back to the 400 page)

After trying to change the icon of a plugin to an image that is too big

Cannot reproduce.
Please try disabling all extensions you’re currently using, or try this in an incognito session / another browser without extensions enabled.

But if it also doesn’t work in studio when I upload a plugin icon doesn’t that mean its not a browser issue?

That’s not what you described in your thread?

This bug prevents me from uploading decals through the Roblox website, but it works when I upload decals on studio.

Please make sure your thread is accurate and you’re providing sufficient information. Performing basic troubleshooting will help narrow down the problem.

Have you tried a different name for the asset? Sometimes the filter can return odd error messages when uploading assets.

Can you open devtools and take a look at the console and network request’s details, and corresponding response for any clues? If you share screenshots, be careful you obscure your cookie or any strings you’re unsure are safe to share.

If this doesn’t work in Studio either, do you have another computer on the same network that you can try? Maybe your network is the problem.

1 Like

Seems to work on my phone on a different network :huh:

Still doesn’t work on my PC for some reason. I’ve tried turning off extensions, using a different browser, using a different file name.

Edit: I tried using a different image and it worked :shock: I got this error
image , guess it’s too large :stuck_out_tongue:

1 Like

Having the same issue. Anyone figure out a fix?

Reduce the pixel count or make the image size
smaller.