HTTP Request Causing Studio to Break

This issue is a bit of an odd one for me. I just got a new computer (XPS 15, i7 11th gen, 32 RAM) and whenever I run my game which gets data from an external server the studio breaks. This does not happen on my old computer. I’m trying to figure out if this is an error with Roblox studio or an error with the permissions on new computer. Any help with the issue would be great.
`This is the HTTP request code but I know that it works

	response = HTTPService:GetAsync("" .. i)
	info = HTTPService:JSONDecode(response)

What is the error that you are getting? Also check the roblox status page

There is no error, it just breaks. This has been going on for a couple of days. Separate from the downtime a few minutes ago.

How does roblox studio just break?

Make sure you’re not using any loops.
Also does the code works on your old computer?

Does the studio close’s itself?

The game won’t fully load in. The player doesn’t get added to the server. It often crashes studio when I try to end the session.

There is a loop, but the loop isn’t the issue because it breaks on the HTTP request on the first iteration.
I also know the code isn’t the issue because it works on my other computer and has been working in-game for over a month.

Go to studio settings and try changing the rendering options.

If that wont work, try posting a bug report.

Getting Crash Report


Send it to the moderators

It’s not a rendering issue. I tried what you said and it didn’t work. I’d love to post a bug report but unfortunately I can’t. It wont let me post in that section.

Go to the files, open the crash report PM the Staffs.

Crash report should be look like this:

DM @Bug-Support, they’ve helped me make bug reports before.

Why would the loops be an issue? I think they might be, but I’m not sure why.

I’ve added a loop without wait so it runs faster, then my studio crash with “roblox has crashed” problem. (on my old laptop)