HTTP Service Requests failing with "number of requests exceeded limit" since Saturday

The HTTPService has began returning a large number of “Number of requests exceeded limit” & “HttpError: ConnectFail” errors. I have validated that I am indeed not violating the request limit, and that the issue is not on the end of my web server. I have included an image of the graph showing when the errors started happening – the green line is the one worth looking at. Additionally, I have included a table of the most recent errors for my game.

A private message is associated with this bug report


Hi, we are actively looking into this. Seems like the core issue is “HttpError: ConnectFail”. And “number of requests exceeded limit” could be caused by retrying logic for the failed request.

In the meantime could you share more info to help us investigate the ConnectFail error? For example, the endpoint you call, the http method, the headers you send, and if you are using a long pull connection? Thanks.


Appreciate the reply. In this scenario, I am certain that I am not exceeding the HTTP service’s request limit – I have noticed for a long time that it returns this error without actually exceeding the limit in some scenarios. I hit two endpoints, one 120 times per minute maximum, and the other 10 times per minute maximum. In the up-to 120 requests per minute scenario, I’m doing a post of a JSON body, and I wouldn’t classify it as a “long pull connection”, the request completes in a couple hundred milliseconds at maximum, generally. I can DM you the endpoints if that’s helpful?


Are you sure this isn’t an issue with the endpoint you’re trying to access itself, rather than an issue with HttpService? You could be getting rate limited.

1 Like

Yes please dm me, that would be helpful for us to further investigate on this.

1 Like

I am also receiving HTTP 403 (Forbidden) errors when trying to POST. This seems to be a Roblox issue since I haven’t changed the scripts in a while.

1 Like

Hmm if you see a HTTP status code then it means the request fired successfully and HttpService returned the response to you. If it is a Roblox issue you may see error messages (like HttpError: ConnectFail in this thread) instead of those failing HTTP status code.
It sounds like a permission issue of the endpoint you are calling - did anything on the 3rd party server side change, like authentication?
If it still persist for you - let us know for more details and we can take a further look!

1 Like

Others are having the same issue. It seems to happen often with discord webhooks with proxies. The creator of the proxy also claims that it is a roblox issue as they did not change anything (neither did us devs causing the issues). However, the proxy doesn’t seem to be the issue. I used RequestAsync with a POST method on the webhook URL with the proxy and it worked. However when I tried PostAsync, it did not work and errored with the HTTP 403 Error.

1 Like

I have the same issue here, when i am hosting this proxy by lewisakura, on my server.
And nothing has been changed on my end, on the server.
Both 403 and 503 are a few of the HTTP issues I get.

I’ve also started experiencing this in recent days. No changes have been made recently on the web server side, nor the in-game code. I do not appear to be violating the 500 req per minute limit and am not using a long pull connection.


I’ve recently started having this issue although I have a queue system that does not allow more than 300 requests per minute. It seemingly doesn’t matter how slow and will still eventually give this error it seems like. However, I am some sort of long polling but at a rate of 12 times per minute no matter the number of players.

In My Movie, we use HttpService for image searching. When there’s problems searching images, it has a direct impact on our player counts–at our peaks, image servers going down dropped our concurrent player counts by several thousands, and fixing it raised them back up. We know this is a bottleneck for our success.

For the past several months we’ve received constant reports of errors in image searching. I’ve only had time recently to look into it, and to my surprise it looks like we are well under the 500 requests per minute limit.

On the left is the P99 of requests being sent every minute. Each color is a separate source of HTTP requests. The highest sum of these on this image is about 60. If we assume that Roblox’s reset timer is offset from mine, it can at best be double, 120.

The right graph is the number of times that an HTTP request is throttled for exceeding limits.

Furthermore, this data is based off of only servers which have this new tracking. At time of writing, these charts are based on only about 150 people, mostly on small private servers (which are definitely not hitting the limit).

Alongside this tracking, I also count the total sums of requests that I’ve sent in the past 60 seconds at the time of the limit being hit.

The sum of requests here makes sense given the low player counts of the servers on the new version right now, I believe them more than I believe there’s a large amount of missing untracked requests.

This is seriously limiting our game’s success.

I spoke with the Roblox staff further in DMs, and we ended up narrowing it down to being caused by the new server pre-warming feature. They disabled it specifically for my experience, and the issue has since gone away. This looks to be exactly the same experience that you’re having, and I figure they could probably do the same for you until they do a proper resolution. cc @LiahnovTechenski

1 Like

If this is a platform-wide issue, I think there’s a lack of communication and a band-aid fix should be available for all.

1 Like

Hi all - we just made a fix today to address the request exceeded limit issue, could you try again and let us know if the issue happen again to you?


Spoke with Brain and one other dev, seems the rate limiting issue is gone now. If anyone else still experience this - feel free to create a new post with details and we will investigate.