HttpService Error 404 (Forbidden) When PostingAsync

According to this post, setting the game access to public may resolve the issue

Yeah, I saw that. I made the game public but the same error occurs.

May not have anything to do with it, but you misspelt webhook (its a variable name, so if you did it wrong twice, then it shouldn’t matter)
Also, what is the URL/Value of webook

The variables are the same name, so it shouldn’t create any errors. The value of “webook” is just a discord webhook so it shouldn’t be posting any errors, I left that part out of the script for safety reasons.

Full script: (Stared the last parts of the URL)

local webook = "**********************************"

local httpsService = game:GetService("HttpService")
local ReplicatedStorage = game:GetService("ReplicatedStorage")
local chat = game:GetService("Chat")

local Events = ReplicatedStorage:WaitForChild("Events")

local function filter(text,player) 
	local msg = chat:FilterStringAsync(text, player, player)
	return msg;

	local formatted = httpsService:JSONEncode({
		content = "Reporting: "..filter(user, player).."\nReason: "..filter(reason, player);
		username = player.Name..":"..player.UserId;
		avatar_url = ('' .. player.UserId .. '&width=420&height=420&format=png')
	httpsService:PostAsync(webook, formatted)

Is http service enabled or not

Yep, as well as the game being public, so I’m not sure why there’s an error.

I mean if it works normally ingame it could just be a studio bug.

It doesn’t work in-game, but works in studio so I’m confused on why.

Ah use a proxy because discord blocked all connections.

I can list some proxies for you.

Use a proxy, Discord has blocked Roblox UserAgent and probably wont restore it. Here is a good one: Discord Webhook Proxy

1 Like

You are not formatting the table correctly it should be:

local formatted = httpsService:JSONEncode({
		["content"] = "Reporting: "..filter(user, player).."\nReason: "..filter(reason, player),
		["username"] = player.Name..":"..player.UserId,
		["avatar_url"] = ('' .. player.UserId .. '&width=420&height=420&format=png')

Make sure that the Webhook URL is correct is a proxy I can list a webhook example.***************************

Proxy isn’t needed because requests to discord aren’t blocked as for

They are. Whole Roblox UserAgent is blocked.

Discord blocked all connections to roblox I mean so you have to use a proxy.

What?! Since when? I used it recently and it worked fine

1 Like

Well some people started spamming it and just abusing it so they blocked all connections. It also depends on what your using it for.


Now discord has blocked all connection of robloxAgent.


For a while already, I have solved 2 of these topics and an official bug report was also released of this even tho it is not a bug.