HttpService taking 20s+ to return requests in Play Solo

Hey all,

I’ve been experiencing this issue for weeks now, and its absolutely destroyed my workflow. Basically, whenever I use RequestAsync in Play Solo, and sometimes in Run Mode, it takes upwards of 20+ seconds for a single request to complete. I’ve tried using different websites, I’ve tried it on my laptop, I’ve tried changing the DNS on my computer AND my router, ethernet vs WiFi, checking all my studio settings, reinstalling studio to no avail.

Is there a hidden setting somewhere in studio that delays the HTTP requests? The links I attempt to ping load up instantly in Chrome, so it leads me to believe that it’s something inside studio. What do I do?

Edit: I should add that the links I do ping return near immediately in game.

Very bizarre, I’m thinking it could be that you need to reset your studio configs to default, reinstall studio, and/or maybe check your plugins? If not your internet connection nor those options, perhaps contact roblox support?

I connected to my hotspot and now it seems to work flawlessly. So I’m thinking its a DNS issue. Tried switching to Cloudflare’s DNS and even installing the Cloudflare WARP tool and that didn’t help at all either. I’ll keep tinkering :stuck_out_tongue:

Roblox Studio is just like that, just like how in data stores it some times does not detect player leave in test unless it’s in a BindToClose function. That’s also dependent on the proxy you’re using.