Humanoid would not rotate when moved to part

To put this briefly, my humanoid would not rotate when I tried to call MoveTo() function on it. I’ve never seen this happen before when I used it.

A video:

My Script:

while wait(1) do
	local e = game.Workspace:GetChildren()
	local saba = false
	for i, v in pairs(e) do
		if v.Name=="food" then
			if (v.Position - script.Parent.UpperTorso.Position).magnitude<=13 then
				saba = true
	if saba==false then

Your humanoid ? I don’t think humanoid is a physical thing are you talking about the npc/player, the human doesn’t have a position or rotation. Correct me if im wrong. I didn’t search the error in the script I’m just asking, Also do you get any error message ?

Please reread what I said and watch the video. The humanoid/dummy will move, but it does not rotate based on the movement. Other instances where I have tried this the humanoid/dummy will move and rotate to the desired part.

I thought you were talking about an actual humanoid, anyways why would you’re humanoid rotate the
move to function implies it ? Humanoid | Documentation - Roblox Creator Hub

In the wiki, it shows the humanoid rotating when it is moving to the moving part. In mine, it doesn’t.

The humanoid’s parent which is most likely a model has a root part right ? is it facing in the wrong direction ?

Nevermind. I figured out the real nuance here. The problem was that the big red cylinder attached to the body was not set to massless, causing this phenomenon.