Humanoid:ApplyDescription() results in improperly scaled accessories


I’ve run into a strange problem recently when I was attempting to make an NPC in Studio which would take the appearance of a Roblox user’s avatar on spawn. I wasn’t sure how to go about this, so I looked it up and discovered the Humanoid:ApplyDescription() function. It sounded perfect for me, so I used the simple line of code below.

-- Server script directly inside of the NPC's Character model.

However, when I tested the script the accessories were all over the place. Every single accessory seemed to have been welded to a point slightly behind the character’s head.
[ The result of the code versus what the avatar should actually look like. ]

I was unable to find anything when I looked it up, only old inconclusive dev-forum posts. I figured bumping old threads wouldn’t yield any results, so I decided to create my own post. I know that I’m not the only person experiencing this, and I know there’s a definite solution out there because I’ve seen the exact result I’m looking for working flawlessly in popular experiences before.

Any help would be appreciated, thank you!

I am aware of the countless plugins and other tools that can help load avatars for you, however I am trying to learn how to use this feature properly to be able to load certain things such as the avatar of a characters’ friend in the future. I know this would require some sort of API rather than using game.Players, but for now I want to solve the hat issue first. Thank you for understanding.

1 Like

Try parenting the accessory’s to something else and wait (Or task.wait) a small amount and reparent them or something

I forgot to mention it in the post, but I tried this and it gave the same results. I’ll try it again differently sometime, but I can’t right now.

Does it work in client / in play mode?

Not yet, but that’s the objective. I want to be able to load a user’s avatar onto a character in the game via UserId after it has started.

Try cloning the accessories?


I’ve been able to load you in without any errors.
What rig are you animating?

This happens with neck items when I import from the moon animator rig thing, try taking out the humanoid for a small period of time and put it back in?

Well, I feel stupid now. The R6 rig I was using didn’t have all of the proper attachments so the accessories all defaulted to the same point. I retried with a newer rig with all of the needed components and it worked fine. Thank you for your reply, though! I don’t think I would have thought to check the rig itself otherwise. Case closed!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.