HumanoidDescription not applying?

I set up a test script for a VR game. Im trying to increase the player Head scale, for some reason the player head will not increase. The HumanoidDescription HeadScale value does change however the character head doesn’t actually scale up.

local HS = 50
local hS = HS/4
	local LHAND = game.ServerStorage.Character.LHAND:Clone()
	local RHAND = game.ServerStorage.Character.RHAND:Clone()
	LHAND.Parent = plr.Character
	RHAND.Parent = plr.Character
	--HHead.Name = "HHead"
	--plr.Character.Head.Size =,HS,HS)
	LHAND.Size =,hS,hS)
	RHAND.Size =,hS,hS)

	local hum_desc = game.Players:GetHumanoidDescriptionFromUserId(plr.UserId)
	hum_desc.HeadScale = 50
	local hum = plr.character:FindFirstChild("Humanoid")

I got no clue what is happening and the articles surrounding this don’t seem to help much.

You don’t have to apply a HumanoidDescription for that, you can just change the value in the character.

Where would I change that value?

You might want to look in this post.

I don’t have a HeadScale normal value inside of my humanoid, only the HumanoidDescription. I figure that the old Normal Values were replaced with the HumanoidDescription.

I tried your script, It did apply for me. Kindly check for any errors in this or any other script(s).


Hmm must be the VR then thank you.

If your problem has been solved, kindly mark a reply as a solution, as it would help others.