Humanoid:MoveTo not working

  1. I want to make this character move to a part. Keep it simple and clear!

  2. At first there was an error but I fixed it. Now there are no errors but the character is still not moving. take into note it is not the player it is an npc Include screenshots / videos if possible!

Dev_Simphony's Place Number_ 18 - Roblox Studio 12_05_2021 09_57_47 (2)

local Monster2humanoid = game.Workspace.Monster2.Humanoid
local monster2Destination = game.Workspace.Destination

the humanoid character is anchored…maybe?

or the character is welded to an anchored object

1 Like

yeah I gotta check that you may be right. Thanks for reaching out!

it works now but why isn’t he animated :laughing: . he moves with no animation which is very creepy. how do I fix this? is it because I made him bigger

the character moves instantly, it shouldnt have any animation

1 Like

I see so I need to make another script for the animation? sounds good. thanks for the help guys

1 Like

Do you want the character to walk to part or something?

You can lauch test into studio, take the script of the animation from your character and put into monster’s one

1 Like

The reason why it’s not animating is because you aren’t telling it to in the script.

awesome. Thanks, it is now working!!

1 Like