Hyper X Cloud S Headset incompatible with Roblox Spatial Voice

Reproduction Steps
Plugging in the Hyper X Alpha S headset and using the output and input.

Expected Behavior
To be able to hear other players and see the microphone icon appear above their heads when using the Hyper X Alpha S Headset.

Actual Behavior
When the Hyper X Cloud S is plugged into your computer, it gives two options for output : headset (game) and headset (voice) and you can set your input to your mic or the headset mic.
In game you can talk and others can hear you but you can not hear anyone else nor can you see anyone else’s microphone icon over the player’s head.


Unplugging my headset. (Hyper X Alpha S)

Issue Area: Engine
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-11-08 00:11:00 (-05:00)
Date Last Experienced: 2021-11-09 00:11:00 (-05:00)


same thing’s happening to me but with my razer headphones


I’m experiencing this issue as well but with Astro A50s. Working around by turning my headset off and using my speakers.


I’m having this same issue with my HyperX Cloud Stinger.

It can’t be that. I switched to my old laptop and plugged my Razer Blackshark V2 Pro into it and I was able to hear others. Just not on my main PC.

But yeah, experiencing the same issue.

UPDATE: Are you sure it’s a headset issue? Tried a non-razer product and another razer product, no fix.

Having the same issue with Hyper X Cloud Core.

Not sure but I think the problem was resolved, I plugged my hyper X cloud s back in today and it worked… can I get a confirmation from others on this thread? Thanks!

Plugged mine out before I turned on my PC and it worked, it may be it?

Yeah I believe it was resolved, my a50s have been working now.

1 Like

Sorry for reviving a dead topic but I found a solution my issue since re-plugging didn’t fix my issue.

I was using a 24bit 192000hz in microphone properties, while the solution was to change it to a lower 16bit frequency.

The issue was probably resolved for other people since plugging your cable into a new jack gives the default settings to their mic’s hz/bit depth.

I accidentally fixed the issue when I changed my microphone’s audio quality in settings to make my mic sound worse in a call with friends. I then joined a VC game and it worked like a charm.

Have you tried unplugging it until you boot your pc and launch Roblox? That resolved my issue permanently.

This issue seems to be solved. If the issue starts recurring, please file a new bug report.

1 Like